Skip to main content

Option to turn off 'search as you type' (Filters tool > search field)

Comments

6 comments

  • Propheticus

    I think this can be fixed by adding a timeout to the search. Only start a search after no keypress has occurred for 500ms. This would prevent searches being started for every substring of the complete string being entered.

    Instead of searching for I & In & Inp & Inpu & Input, it would only do a search for Input. This prevents wasting resources on (parallel?) search operations that return data that is never used.

    1
  • Thomas Kyhn
    Top Commenter

    Capture One appears to have a timeout already. If I type "input" fast, I can type the whole word before Capture One becomes unresponsive.

    In any case, as long as every search operation causes Capture One to become unresponsive, it makes no sense to have 'search as you type' enabled.

    0
  • Propheticus

    True, but conversely being able to turn it off would also not solve it.

    0
  • Thomas Kyhn
    Top Commenter

    How do you mean?

    0
  • Propheticus

    You explain it's not due to multiple substrings being searched simultaneously that searching leads to unresponsiveness. Even a single search apparently already does this. Then it's the search operation in of itself causing the issue, not the search as you type implementation. (Of course pausing halfway typing your phrase is problematic). Turning off this feature would not make the single search perform any better.

    But I agree it also doesn't really add anything useful unless search performance (or at least ui blocking behaviour) is improved.

    0
  • Thomas Kyhn
    Top Commenter

    Indeed, the basic problem is unresponsiveness when searching, but I doubt that this will be fixed any time soon. Turning off 'search as you type' would at least limit the number of times Capture One becomes unresponsive when searching.

    0

Please sign in to leave a comment.