battery saving causes c1-20 to redo hardware accel check.

Comments

8 comments

  • Paul Steunebrink
    When you switch from mains outlet to battery power, the computer may switch to another (less powerful and less power consuming) GPU. Apparently, Capture One detects the change.

    If you do not want the repeated hardware acceleration checks, what I can understand, your best option is to disable the feature.
    0
    Comment actions Permalink
  • Gustavo Ferlizi
    Normal behaviour as far as I can tell. Seems to recompile the OpenCL kernel or something like that.

    Happens every time CO starts up and sees that the active hardware engine is not the last one it started with. Even if it's always the exact same iGPU - dGPU switch.

    I'm on a laptop with intel graphics only, but when I dock it to an external GPU, there goes 10 minutes.

    Actually it's at least predictable for me, because I can exit Capture One with the eGPU plugged in, unplug the eGPU, go about other business, switch off, come back another day, plug the eGPU first, and then start up Capture One. In that order it doesn't complain and just runs.

    Pièce de résistance.
    0
    Comment actions Permalink
  • SFA
    I had some interesting things happen with GPU checking at startup.

    My elderly notebook has an old i7-38xx series CPU with the Intel internal graphic stiff and a not much more powerful NVidia Quadro dedicated unit. The Quadro is just about useful so it gets selected.

    In earlier versions the Intel would be identified as "Failed" (to be acceptable) after the first check after a forced refresh and the Quadro would be found, assessed and retained. All fast enough that it was barely noticable.

    With V20 the process started to fail. For some reason, possibly a Windows 7 update the Intel options, being Unit 0, was found and assessed first and started to fail (rather than be assessed useless and rejected, at about 96% of the way through its assessment. The log file showed the fail. Activity monitor stopped for quite a while at about 43% (iirc) and the the process crashed.

    Meanwhile the Quadro's assessment (Unit 1) had started but never finished since the assessment process crashed.

    I could switch back to V12, the process would run again and could work.

    In the end I found that running the process a second time did not attempt to re-assess the Intel GPU, would re-assess the Quadro (in a couple of seconds) and all was well.

    Also, apart from making sure the Activities Monitor is OPEN when one closes C1 so that it is also Open when C1 is restarted and thus shows the GPU assessment process running, the Preferences settings tab for Hardware Acceleration has a message beneath it that indicates whether C1 believes it is actually using hardware acceleration or not.

    Now as far as I can tell the check is actually run every time C1 starts - presumably this also means that a check is made for any software/driver changes rather than just assuming that people will force a rebuild if they have changed the drivers (if they know the drivers have been changed.). As, normally, in a non-changed environment that should take almost no time at all it seems like a good idea.

    But of one or more of the "GPUs" is struggling with some sort of issue - for whatever reason - it might take a while and, unrecognised, the problem could easily persist for some time.

    Obviously if people are in a state of switching back and forth between versions the rebuilds are likely to be more often and perhaps leave more potential for things to go wrong. Once one has moved on more or less permanently one might expect it to fade away.

    Has anyone else spotted a similar pattern of events?


    Grant
    0
    Comment actions Permalink
  • andy wee
    no idea. but i was hoping for some startup commands for c1-20 to disable check or allow to cancel the benchmarking of the GPU.
    because my dGPU is a 150w quaddro internal dGPU, it doing the benchmarking consumes alot of power. not to mention my CPU is a 2286m. that mobile CPU at peak does 75w. so meaning c1 starting up with a dGPU disabled consumes an unnecessary 10-15% battery? I have already forced nvidia control panel to use dGPU when executing captureone.exe. infact I have added all the exe to it's exclusivity but it's not helping.

    I know there are commands for c1-20 to startup differently.
    when I had a IQ280 there is a command for c1 to not be multithreaded so that the segmented CCD could be processed linearly.

    I'm wondering if i should ask Peter from C1 if he knows of any additional commands for c1 to start without doing benchmarking. the key isnt with the AC and DC thats causing the trigger. but rather. when one turns on power saving, windows shuts down the dGPU for further powersaving.

    with this issue happening, capture one is starting to look like a battery hogger for no reason.

    for now i either disable hybrid GPU and go full discrete or deny capture one of dGPU with the use of nvidia control panel and thus make capture one one of the slowest imaging application.
    0
    Comment actions Permalink
  • SFA
    Sounds like power usage is a big concern for you.

    If so why no just turn off hardware acceleration and simplify the system settings?

    I don't think you need to use the nVidia control panel to force use of the GPU for C1 so long as the GPU has sufficient performance to be judged usable. Yours clearly does and should be adopted anyway assuming that the driver is compatible and the assessment program has completed successfully - which should only take a second or so after the first run. Basically a check that what is available is what has been assessed already and if not - re-run the assessment.

    Have you checked the log files to see what activity is being reported?

    Are you starting C1 with the Activities window displayed so that you can observe what significant background activities are taking long enough to be visible?


    Grant
    0
    Comment actions Permalink
  • andy wee
    i just went thru all the various log files. it seems that enabling "battery saver" in win10, it disables c1-20 to access dGPU OpenCL. I guess I have to set Battery saver to be less agressive or completely turn it off. it also seems that if battery saver is enabled after the preset percentage. c1-20 becomes unstable.
    0
    Comment actions Permalink
  • andy wee
    I just did a test. Even if you set hardware acceleration to off. It will still do the benchmark with no means to cancel.

    Just exporting 28 2048px jpg took 9mins.
    The benchmark said it would take 25mins to run.

    Some of my laptops are those ultra light notebook like HP envy and spectre. So just to quick export of IIQ to jpg. Lightroom exports way faster than capture one because of this reason.

    Yap you heard right. LIGHTROOM FASTER THAN.CAPTUREONE.
    There has got to be a way to cancel benchmarking.
    0
    Comment actions Permalink
  • Gustavo Ferlizi
    Yep, two things I would like to be able to cancel.

    Preview generation and HW acceleration initialisation.
    0
    Comment actions Permalink

Please sign in to leave a comment.