Skip to main content

Naming as part of Process Recipe?

Comments

22 comments

  • Ian Wilson
    You could create a recipe for a particular competition. In Output naming in the Output tab, one of the tokens you can use is called Recipe Name. You could use that, if you named your recipe appropriately. Or put a name in Job Name such as "XYZ competition" or whatever the rules for that competition say it must be and then use the Job Name token.

    Ian

    Edited to add: and see this video telling you almost all you want to know about process recipes, including naming options.
    0
  • NN635085536502500483UL
    Thanks, I understand what you are propossing, but it doesn’t help. First of all I still have recipes where I want to keep the original file name.
    But also the name requirements vary from competition to competition. For example some wants the title of the picture (title tag) as filename and others wants photographers name.
    All is possible but not just individually for each recipe.
    0
  • Paul Steunebrink
    jhammerstad wrote:
    (...)
    Is it in any way possible to control the naming of the output file so that it only applies to one recipe?

    Yes. For this purpose, each Process Recipe has a field for Sub Name on the File tab and what you enter there is unique for that recipe.

    Here you enter the value for the token Sub Name that you use in the Output Naming tool. In that tool, you add other tokens, text, sequence number or whatever as prefix or suffix to the Sub Name token.
    2
  • Jan Hammerstad
    Thanks, I tried it prevously but couldn't make it work. I'll try again 😊
    0
  • Paul Steunebrink
    jhammerstad wrote:
    Thanks, I tried it previously but couldn't make it work. I'll try again 😊

    Success! Keep us posted if you like.
    0
  • Jan Hammerstad
    I am sorry, but I still cannot get it to work 😊

    In the metadata the "IPTC - Status / Title" is set to 'Pakistani Bride', which is what I want to use as filename.

    In a new Process Recipe I have set 'Sub Name' to '{Title}' (the token) and 'Sub Folder' to 'Konkurrence'.

    The picture is correctly put in the 'Konkurrence' subfolder under the Output-folder, but the filename on the output file still comes out as the original filename (CF028505.jpg), as seen in the Process Summary panel.

    Am I completely misunderstanding something here?
    I can show you some screendumps if you like?
    1
  • Jan Hammerstad
    Oh, and btw, when I define the 'Naming format' the 'Sample' correctly shows the Title as filename - and any other token I use.
    But the output filename and the Process Summary does not ...
    0
  • SFA
    jhammerstad wrote:
    Oh, and btw, when I define the 'Naming format' the 'Sample' correctly shows the Title as filename - and any other token I use.
    But the output filename and the Process Summary does not ...


    Is the Process you are modifying the same process that is being used for the output - bearing in mind it is possible to have multiple processes active on the same batch run?
    0
  • Jan Hammerstad
    Yes, only the one recipe is selected.

    You can see a screendump here of all (I believe) the necessary tools:
    https://www.dropbox.com/s/2xz3n9o6ylkbw ... 7.jpg?dl=0
    0
  • SFA
    jhammerstad wrote:
    Yes, only the one recipe is selected.

    You can see a screendump here of all (I believe) the necessary tools:
    https://www.dropbox.com/s/2xz3n9o6ylkbw ... 7.jpg?dl=0


    I don't see a problem using that field running on Windows 7 with (currently) V11

    However I'm not starting with an IIQ file as your screen capture seems to suggest that you are starting with.

    It would be worth testing (it you have not already done so, with a jpg file (for example) rather than an IIQ "package" file to see if that makes any difference.

    HTH.

    Grant
    0
  • Jan Hammerstad
    Thanks, I am running CO12 on Windows 10.
    And I did test on both jpg, tiff and iiq 😊
    Same result.

    But we agree that these settings should produce a file that is named with the Title metadata, right?
    0
  • OddS.
    jhammerstad wrote:
    ...But we agree that these settings should produce a file that is named with the Title metadata, right?


    That is what I would expect, and it is also what I get (Win10 C1 12.0.2) when using settings indicated in your screenshot.

    Edit: Forgot to mention that I tried with Nikon .NEF files.
    0
  • SFA
    jhammerstad wrote:
    Thanks, I am running CO12 on Windows 10.
    And I did test on both jpg, tiff and iiq 😊
    Same result.

    But we agree that these settings should produce a file that is named with the Title metadata, right?


    Try clearing the Process History and then re-running the Output process. Any different?
    0
  • Jan Hammerstad
    Hi OddS and SFA,

    Just tried with a NEF as well - same result - only the original filename.
    Also tried clearing process history - same result.
    0
  • SFA
    jhammerstad wrote:
    Hi OddS and SFA,

    Just tried with a NEF as well - same result - only the original filename.
    Also tried clearing process history - same result.


    That's odd.

    I could see something that might have been the same problem bit only the second time I attempted to process the same file.

    You could try making the Title the entry for the Sub Name (as you have already) and then use the Sub Name token for the file naming (NOT Title for this test.) Then see what happens.

    There does seem to be some sort of issue but it is not one I have seen before so I am sort of thinking it may be specific to the particular field in use. Right now I can't think of any reason why that should be UNLESS it is something to do with name length and the potential length of the field related to the token.

    OR some conflict for the use of the token name.


    Grant
    0
  • OddS.
    jhammerstad wrote:
    ...Also tried clearing process history - same result.


    On a couple of occasions, versions 11 and 12, the support team adviced me to completely remove Capture One and install from scratch to fix some issues. Remove included deleting user C1 data folders (not session/images). All settings gone.

    I think you should report the issue to Phase One support.

    Now switch to speculations mode:
    All file systems have a set of rules for naming files and folders. If writing to a file named from the Title field somehow violates a file system rule, C1 will perhaps revert to the original file name.

    I can not tell from your screenshot, but is there a remote chance that the target is a disk formatted for a file system that only accepts file names on the 8.3 format? Try changing the title field to a text shorter than 8 characters using only normal characters [A-Za-z] (no space chars) and see if it makes a difference. If it does, revert to the original Title and change the recipe to point to a scratch folder on your C: drive for output, and try again.
    0
  • Jan Hammerstad
    H OddS,

    I had been thinking about the file system as well. But I am using NTFS. I have also tried simply using eg. a Sequence-token instead of Title-token. This should only produce a very short filename.
    Also some of my pictures have short titles, eg. 'Portrait', 'Shy', 'Red' etc.
    - but still same result 😊

    I am going to talk to support Monday morning 😊
    0
  • Jan Hammerstad
    Also, if I insert the tokens in the 'Sub Folder' the new folder is correctly named as the token value. But still filename is left as the original.
    And also, behaviour is the same on two different PCs...
    0
  • OddS.
    jhammerstad wrote:
    ...if I insert the tokens in the 'Sub Folder' the new folder is correctly named as the token value.


    Intriguing! Let us know what the Support team suggests.
    0
  • Jan Hammerstad
    I think, I figured it out 😊

    'Sub name' only works when the token {Sub Name} is added to the Format in the 'Output Naming' tool.
    Default for the format of 'Output naming' is only the token 'Image Name'.

    What I want to achieved is to have different naming in each Process Recipe.
    Setting 'Output Naming'/Format to the {Sub Name}-token, and setting 'Sub Name' in Process Recipe to whatever tokens or text I want for that recipe, I can do that.

    I now have a recipe 'Competition' where the Sub Name is the {Title}-token.
    In the 'Output Naming' tool format is set to the {Sub Name}-token.

    In all other recipies I just have to remember to set the 'Sub Name' to the {Image name}-token. Then I'll get the original filename.
    1
  • Paul Steunebrink
    jhammerstad wrote:
    I think, I figured it out 😊

    'Sub name' only works when the token {Sub Name} is added to the Format in the 'Output Naming' tool.
    Default for the format of 'Output naming' is only the token 'Image Name'.

    Isn't that exactly what I wrote on the 2 Feb in this thread (3rd reply)?
    1
  • Jan Hammerstad
    Yes, it was when I re-read it. But I understood it differently at the time. 😊
    1

Please sign in to leave a comment.