Skip to main content

Mac OS 10.5.x requirement for C1 4.5?

Comments

1 comment

  • Ulf Liljegren
    Hi
    This is correct
    Capture One 4.x only works on Mac OS 10.5

    While:
    Capture One 3.7.9 works on Mac OS 10.4.x and 10.5.x
    0

Please sign in to leave a comment.