Zum Hauptinhalt gehen

⚠️ Please note that this topic or post has been archived. The information contained here may no longer be accurate or up-to-date. ⚠️

Capture One (any version) on M1 Macbook Pro Buggy Error-ridden Won't Capture Images AM I ALONE?

Kommentare

34 Kommentare

  • LVS

    I'm not sure how C1 is developed but I suspect they have not fully integrated C1 into Ventura and M1/M2 architecture.

    Things to try:

    1. If you have ever done a Firmware update to Sony camera, make sure that you restored the normal Security Settings in the Startup Disk on Ventura.
    2. If that's not the issue then proceed with these:
    3. From Finder, locate the CaptureOne23 Application and right-click and select Get Info
    4. Put a Check mark in Open using Rosetta
    5. Start the application and see if anything has improved.
    6. if none of that works then try Deleting C1 and re-install

     

     

    0
  • LVS

    One more thing: Make sure that Airplane Mode is ON so the camera is not attempting to connect to wi-fi.

    If you have Google Drive, turn it off.

    0
  • suzanne clements

    Great suggestions, I'll do a test this week and report back. Thank you!

    0
  • Kevin Robinson

    Hey Suzanne,

    Take a look at my recent post in the “Constantly being asked to sign in” discussion. The sign in and activation issue has been resolved on the C1 server side.

    In regards to your "live view is not supported for the connected device using ptp" issue, I have no answer on that, as I’m still running C1 v22 (15.4.2) on an Intel MacBook Pro under OS Monterey 12.6.3 without issue using Fujifilm & Nikon cameras. I suspect when I upgrade to C1 v23 it will be the same for the MacBook. I’ll give it a try it on my M1 Mac Studio. Have not seen anything with C1 requiring the Rosetta option. I do have some older plugins running in Photoshop that require it, but nothing like that is required in C1. Have you submitted this issue to C1 Tech Support???

    You asked “Am I alone on this? Is anyone else running into M1 problems in CaptureOne?” The short answers are no you’re not alone and yes I’m seeing problems with C1 my M1 Mac Studio that I don’t seem to experience on my Intel MacBook Pro nor on my older Mac Pro.

    Back in September I migrated from an old 2012 Mac Pro tower to a maxed out M1 Mac Studio Max in order to upgrade to C1 v22 and Photoshop, etc for use with three monitors. 

    My problems with C1 v22 on the M1 Mac Studio have been related to C1 browser navigation issues. I can move from one photo to the next and the photo will show in the viewer, but the browser will not move. In other words I can be twenty photos deep on the browser pics and I have to scroll down to find where that photo is selected. Even happens with full browser view and a list of phots that require scrolling. It’s supposed to scroll the view automatically and at time it does not. Very irritating.

    An ongoing problem for the past few version of C1 has been with the Menu Edit > Undo and Redo wording. It used to track and name correctly, i.e. undo Exposure Adjustment, etc. But now, so often, it just says Reset Adjustments. Not a huge deal, but there are times where I select that option and it would be nice if it would say Undo Section and not Reset Adjustment. I’ll see if it’s finally cleaned up in v23.

    At times adjustments or presets may not apply and my only fix has been to shut down and restart C1.

    When working with C1 and Photoshop, there are times when adjustments made to a PSD file will not update to C1 after selecting save in Photoshop. At times have found it necessary to shut down and restart C1 for the PSD update to show in C1. On a few occasions deleting the PSD file from the C1 catalog and C1 trash, then having to import the PSD file back into C1 for it to work. 

    As a side note… (As so many of us have requested C1 to finally get us full functioning Metadata / IPTC… No I don’t use Photo Mechanic if that’s a thought) I always the delete PSD file from the C1 catalog and C1 trash, then import the PSD file back into C1 before I export from C1 to a JPEG, etc. My primary reason for this is how both C1 and Photoshop fail on the IPTC data portion as I require it for Google. But applying it in Photoshop and importing it to C1 works. Go figure, smh. Probably the same for C1 v23 now that I’ve upgraded.

    Hope some of that helps. K

    0
  • Kevin Robinson

    fyi, my latest post to the “Constantly being asked to sign in” discussion is still pending review. Probably because  I included a link to a Capture One doc, go figure. Anyway, you shouldn't be having anymore Sign In requests.

    0
  • suzanne clements

    LVS Just tried out the Open Using Rosetta suggestion and while the "live view is not supported for the connected device using ptp" error message flashes for a moment, it is quickly replaced by an active live view and it records images shot. I'll do more testing, but so far this looks promising! Fingers crossed!

    Kevin Robinson hooray on the sign-in error! That viewer issue sounds maddening, I don't believe I've run into that, though occasionally it takes AGES for images to load in the viewer... blurry, cycling... eventually snapping into sharp and loaded. Super curious about moving between photoshop and CaptureOne, I've never played with that, but now I'm super curious and need to see what that's all about. :)

    0
  • Kevin Robinson

    Hey Suzanne, Interesting results with using Rosetta. Looks like LVS was on to something with that. Maybe open a support ticket so that the support team is aware of it, your issues and results.

    For using Photoshop with C1, it's a called a round-trip workflow and it's how I roll ;) C1 used to have some videos on their YouTube channel, but they seem to have taken them down. Here is a good YouTube video on the Process using C1 v20 https://www.youtube.com/watch?v=v4dC9Q8nsoI Pay attention to the difference between "Edit With" and "Open With".

    Finally, how did you create the link to LVS and me in your post? can't seem to get it to function on my end?

    0
  • suzanne clements

    Great link Kevin Robinson thanks for that :) To tag someone in the forums use the "@" symbol and then type the username after, select the username from the pop-up and that'll add them to your comment. 

    I sent a support ticket out last week, haven't heard back yet, I'll definitely update them though if I hear back.

    0
  • Thomas Kyhn
    Top Commenter

    Here, Capture One is slower and more often becomes unresponsive without 'Open using Rosetta' checked, which seems to indicate that it isn't properly optimized for M1.

    0
  • Kevin Robinson

    Hey suzanne clements.

    Glad you liked the link!

    LOL! Yes, I know to use the "@" symbol, but overlooked it ;) My problem still, is that some of the folks that use initials rather than a name don't appear up in the pop-up list. For example, on another post I was trying to tag "@C-M-B" and it does not show up. Maybe there is a "don't tag me" option somewhere, but I don't see one. Oh well.

    I'll take a look at Liveview on my M1 Mac Studio and let you know what I find.

    0
  • Kevin Robinson

    Hey Thomas Kyhn,

    It appears that you and LVS are onto something and suzanne clements results seem to support that so far. Hopefully Suzanne will get a tech response that provides us some insight.

    Would be nice if the C1 tech team would address this on the system requirements page. As the only indicated use of Rosetta is with older versions of C1 being run on the M1/M2 platform. There is no talk on that page of current versions requiring the use of Rosetta.

    1
  • Kevin Robinson

    Hey suzanne clements,

    After having upgraded to C1 v23 over the weekend, I had a chance to test C1 v23 with Tethered and Live View this morning and both worked smoothly on both my M1 Mac Studio Max and Intel MacBook Pro, both running OS Monterey 12.6.3 I know your issue was seen with M1 architecture on OS Ventura, so have sent you my test setup.

    -M1 Mac Studio Max
    -Internal Apple SSD
    -Viewsonic Monitors x3
    -OS Monterey 12.6.3
    -Capture One v23 (16.0.2)
    -Rosetta = OFF
    -Fujifilm X series, several models.
    -Tether Tools USB-C to USB-A Cable
    -Tether Tools Micro-B to USB-A Cable

    Maybe you can access an M1 Mac with OS Monterey, to further determine if it truly is a OS Ventura issue.

    Have you heard anything back on your support ticket?

    0
  • suzanne clements

    Kevin Robinson interesting point about the OS. This summer and all the way through until this Winter I was shooting just fine on the M1 chip laptop without any trouble. So it may be the combination of Ventura and the M1 chip that's the problem.

    It will also cause the same issues in older versions of the C1 software, so this is not, in my experience, an issue of just C1 23, it goes back to 22 as well.

    The non-M1 laptop is also on Ventura, but had no problems. 

    I'm just kind of surprised that this isn't getting a louder response of more people chiming in. It makes me curious if there might be something specific to my setup, or if most people haven't yet moved to Ventura who have the M1 chip?

    I personally bounce between my Intel and M1 computers depending on where and how I'm shooting. And my first terrible experience was back in January (I believe that's when I upgraded to Ventura), and I didn't report it until last week so... maybe we're all trying to trouble shoot it first...

    No word on the support ticket, also doesn't look like my updates have yet been read (I have a read receipt on it).

    0
  • Kevin Robinson

    suzanne clements,

    Yep, Intel and M1 here as well. Use my Intel MacBook for tethered shoots and the M1 Mac Studio for my post production work.

    So maybe it's down to a M1 with Ventura issue? But as you said "just kind of surprised that this isn't getting a louder response of more people chiming in”.

    You stated in your original post "Changed CaptureOne software versions (still have an older C1 installed before the 23 switch)”. Although C1 can have two versions installed, I’ve found it to be problematic in my experience.

    So I'm going to make a suggestion... 
    Do a complete uninstall of both C1 versions and then do a clean install of v23 (16.0.2).

    Not sure if if you’ve ever done a complete uninstall. It’s fairly straightforward with only one version installed and it’s been a while since I dealt with two versions installed.

    Capture One has a page on the process, here’s my method:
    #1 - Deactivate both versions individually from within Capture One via the Menu: 
    Capture One > License > Deactivate

    #2 - Back up your Capture One folder. Especially if you have custom styles, etc.
    It’s found in /Users/your name/Library/Application Support
    Access it via Finder > Go > Go To Folder and enter ~/Library/Application Support 
    or 
    In the finder menu open the “Go” dropdown, press & hold the alt key to select “Library” 

    #3 - Run two command lines one at a time, in terminal, to stop the daemons that are running in the background for your versions. I'm assuming you have v22 (15) and v23 (16); if not let me know. You can copy and paste the command lines. Use your right arrow key to move the cursor to the end of the line and press enter. Should run and come back to a line that looks something like Suzanne@MacBook ~ %

    The command lines are as follows:
    For v22 (15):
    defaults delete com.captureone.captureone15

    For v23(16)
    defaults delete com.captureone.captureone16

    I run each of them a second time to confirm it’s done. It will report “not found” with some other data and go back to the entry line. Type exit and press enter. Use the Finder menu to select Quit Terminal

    #4 - Reboot your Mac

    #5 - Use AppCleaner (v3.6.7) to do the rest of the work. You just open AppCleaner and drag the v22 Application Icon to AppCleaner screen and it generates list of what it’s going to remove. Do the same for v23. I grab a screen shot(s) of the list, so I can do a manual check afterwards via Finder, not usually necessary.

    #6 - Do a clean install and registration of C1 v23. Adjust your C1 preferences and close C1.

    #7 - Copy your custom presets, recipes, styles, etc. from your Capture One backup folder to the new Capture One folder installed for v23. I have tons, so it takes me a bit of time. You may not have any custom and just use the defaults. In that case you have nothing to copy over.

    #8 - Open C1 and go from there.

    Here’s a couple links:

    https://support.captureone.com/hc/en-us/articles/360002402377-How-do-I-uninstall-Capture-One-

    https://freemacsoft.net/appcleaner/

     

    0
  • suzanne clements

    @Kevin Robinson followed the steps, oddly when I reinstalled and started up C-1 it tossed up a notice about how I needed to upgrade my catalog and haven't backed it up in X days. I'm guessing the clean-up didn't go all the way. I opened it up, did some testing, no errors etc. Then I thought I'd check and make sure it isn't somehow still opening in Rosetta, but weirdly, that box was checked again. I unchecked, ran a few more tests and it seems ok. I'm going to try and push it a little more this week and get all my gear in the mix to make sure none of the gear is adding to the error generation, but for now (despite the oddness after the clean re-install implying it wasn't 100% clean), it seems to be running without Rosetta. Fingers crossed.

    0
  • Kevin Robinson

    suzanne clements

    The “upgrade catalog” notice is not an error and is totally normal. Happens each time you upgrade to a new major release. Even though you had installed C1 v23, your catalogs were still associated with the older version of C1 that was still installed on your Mac and not upgraded when you installed v23. 

    Here’s why, once you upgrade a catalog or session to the new version of C1 it can’t be opened in a prior version. If you did not see the “upgrade catalog” notice when you previously installed C1 v23, it’s probably because you opted to leave the previous version of C1 installed.

    There is an exception when you upgrade your catalog or session, C1 creates a backup of the catalog or session for the previous C1 version it was created under. You can see the backup catalog or session by doing a right click with your mouse on the catalog or session and selecting “Show Package Contents”, there you will see the catalog or session and another that has the word backup. You can keep the backup or delete it. 

    I have several catalogs and maybe a number of sessions at any given time and I always copy my catalogs and sessions to a folder for that previous version before I do any upgrades. You can name it something like C1_v22_Catalogs. That way if there is a big glitch in a new version, you can go back to a previous one until things are fixed. Or if you’re concerned that a new version may make slight changes to your previously adjusted images, you can decline the upgrade. I’ve never found that to be an issue and do the upgrade.

    I’m sticking with your issue having been caused by there being two versions of C1 installed.

    It sounds like your cleanup went well and things are working good! 

    Post back after you’ve had some time to test. Have a great week! K

    0
  • Jack W
    Admin

    HI suzanne clements – I've asked support to prioritize your case as this seems like a productivity stopper.

    In instances like this, you basically need to strip back to the bare necessities and identify the point of failure.

    Let's stick with the workstation you would normally use. However, making a new user account (just for test purposes) is a good idea, because you'll be starting with a fresh set of permissions and a "clean slate" so to speak.

    Perform a clean install of Capture One on your new user, open Capture One (without Rosetta) and create a new Session. 

    Connect your camera using a USB cable under 2.5m and ensure that the settings on your camera have been reset to defaults, or that you are absolutely using the correct connection option.

    See also the tethering troubleshooting article.

    There are a lot of variants here, so by going back to basics, it will help you/us identify the point of failure.

    Once you have done this, create a logs package that you can include in your support case. We'll dig into these and see if there's anything conflicting or preventing the connection.

     

    0
  • Kevin Robinson

    Hi Jack-W,

    If you go back a few posts, you'll see that I advised suzanne clements to remove both versions of C1 (v22? & v23) that were installed on the M1 Mac and do a clean install of v23. Most responders seemed to have missed the two version installs in Suzanne's original post. As of 2 days ago that seems to have done the trick and without Suzanne's M1 requiring Rosetta. Hopefully we'll get an update after she gives it a few test runs this week. 

    0
  • Jack W
    Admin

    Having multiple versions of Capture One shouldn't be causing problems though, unless there's some database or document confusion between the two. I will take no news as good news :) 

    0
  • Kevin Robinson

    And it's the inability to figure out where that "database or document confusion problem" exists between the two. At that point, a complete uninstall and fresh install is about all we're left with ;) 

    0
  • suzanne clements

    So far so good, no glitches or hiccups, but I haven't run the gauntlet with it yet. I have set up my full mobile workstation with backup hard drives, Apple Studio Display, etc. and crossing my fingers the gremlin has been evicted. I'll definitely report back if things change. I'll be on location again soon and that'll be a great opportunity to see hiccups if there will be any.

    1
  • Kevin Robinson

    That's great news suzanne clements

    One thing I forgot to mention, be sure to run the verification process occasionally to weed out any database issues. You may want to run it at this point. Not sure if you're familiar with it. You can only run the process on an unopened Catalog or Session. I actually run this before I start working in any of my catalogs or sessions.

    Although not necessary, I create a catalog called Verify that has zero images. I open the Verify catalog and select File > Verify Catalog or Session. From there I can select any catalog or session and then select Open.

    The process will run and give you the results where you can select "Verify", "Repair" or "Close". If the test fails, you'll see "Database verification FAILED" in red text. Select "Repair" and the database repair process will run and hopefully report back with "Database repair OK" in green text (or give you that on the initial test run). You can then select "Verify" to double check or just "Close".

    Here are a couple screen shots from a test on one of my catalogs today, FAIL and Repair:

    0
  • Jerry C

    From time to time I see the same error you had, "Checking for catalog folder collections without a project FAILED!" It is the only error I have seen with my database in many years and is always fixed by Repairing the catalog.

    What does this error mean? The error message is confusing. Usually a folder is a folder on a media device (SSD or HD). Folder collections refer to folders on that device. Folder collections cannot contain projects. User collections do not have folders. They have albums, Projects and Groups.

    0
  • Kevin Robinson

    Hey Jerry C,

    My understanding is the verification test is checking the Capture One Catalog or Session file (catalog_name.cocatalog or session_name.cossessiondb) for corruption and also the relationship to the folders and files on the SSD or HD associated with the catalog or session. When a Catalog or Session file gets corrupted or the link(s) to a drive gets corrupted the test fails.

    Yes, the wording is confusing. When we look at the C1 Library we have "User Collections" that contain Albums, Smart Albums, Projects, and Groups. Below that we have "Folders" that show us what "SSD or HD Drives" and related folders and files we have "In Catalog" (this sub-title is just below the "Folder" title).

    So, what I think the error means is that the test is looking at the "C1 Library > Folder > In Catalog > Drives & Files" and checking to see if there is an associated "Project" in the "C1 Library > User Collections".

    In my example above, that catalog does not have any "Projects" at all and therefore none that are associated with the "C1 Library > Folder > In Catalog > Drives & Files" . So does the test fail by default and return a "Checking for catalog folder collections without a project FAILED!", then get corrected upon Repair??? Don't know the answer and I'm just applying SWAG to the results I see.

    Just ran a test on another catalog and got this FAIL. It is a v23 (16.1) catalog and I'm trying to figure out an issue and ran the test. The repair did nothing for my issue. But just wanted to show you another error example. I've seen errors fairly often on different Mac's, OS's and versions of C1 since v8, so that's why I run the test. You may want to open another post if you're concerned and need more insight. I don't loose any sleep over the results, as long as the catalog or session gets repaired. I've gotten into the habit of just running the test before I get catalog or session issues and it has worked for me. It's the other C1 bugs that give me grief!

      

    0
  • Jerry C

    Thanks for the insights. These errors show up when you run the Verify tool on a closed database when they do not when running a backup with the database open. Presumably the Verify tool run on an open database detects a different set or subset of errors.

    Error messages are some of least transparent messages on earth. They mean something to the engineers while telling the user very little. My favorites are the Windows error messages, like "Your computer will self destruct in 10 seconds. OK?" Who dreamed up "OK" as a response you are forced to give to acknowledge the error?

    While Capture One's error message tell little about what went wrong, at least it usually does a decent job of repair.  

    1
  • lisa g simon

    Hi All!

    So I am having major issues with tethering won the m1 MacBook Pro and the new Capture One 23- Same as Suzanne. It show my camera- all the settings and I can even operate my camera (the Sony a7 IV ) from my computer and C1 yet it doesn’t capture the photos. I have downgraded my operating system to Monterey because I read that it wasn’t compatible with Ventura. I have reinstalled the program numerous of times and it just doesn’t work. I contact C1 support and they couldn’t help and eventually just ignored my emails. It is crazy that we pay such a high annual dollar amount for a program that just doesn’t work(sorry venting a little bit because it’s so disappointing). I have only read a handful of the comments and plan on reading them all but if anyone has any insight on how to make tethering work where my photos are captured in the program please advise! Thank you in advance!

    0
  • suzanne clements

    Hey lisa g simon I'm so sorry to hear you're running into this! It is beyond frustrating and any time you need to use the software is any time you REALLY DON'T need this to happen. 

    Running my software in Rosetta (see this reply: https://support.captureone.com/hc/en-us/community/posts/9399116976029/comments/9402686762013) fixed the problem and ultimately I ended up doing a full, complete uninstall of the C1 software (all versions) per this post here: https://support.captureone.com/hc/en-us/community/posts/9399116976029/comments/9438114977693

    Since then I've been running like normal save for one hiccup that deleted my entire session last week while on set for a client... unrecoverable deletion too, btw. The files weren't in the trash, or in the session trash... they just blinked out of existence. I haven't done a test shoot since (been editing files), but I was able to shoot the rest of the day there with no repeats on that hiccup. I had it happen one other time about 10 years ago with no resolution, it's so rare it's pretty hard to troubleshoot.

    I'll be testing everything again today and tomorrow to make sure I have plenty of stop gaps for the deletion issue, but as it stands right now, the capturing files problem is resolved. I hope you get back up and running quickly!

    0
  • lisa g simon

    Thank you so much for responding Suzanne for getting back to me! I am going to try the Rosetta trick and I am keeping my fingers crossed it works! I just find it strange that Capture 1 support is ignoring my requests for help at this point and they haven’t released an update for the m1/m2 laptops. Keep us posted on how your next shoot goes and I will too!
    Thanks for your help!

    0
  • jsmac

    I don't want to hijack this post but it is somewhat relevant to an issue I've been having and the Rosetta workaround is something I was thinking about. The issue I'm having is pixelated Live View at 100%. This makes checking critical focus with Live View on studio still life shoots impossible and something that I didn't experience with my previous Intel Mac.

    I installed C1 22 on another M1 MacBook to determine whether the issue is my MacBook Pro. I opened C1 both natively and through Rosetta but unfortunately the issue persists. So I think I've isolated the issue to Apple Silicon machines running OS Ventura.

    I opened a support case over a month ago but I haven't received any helpful feedback in a couple of weeks. They've told me that they haven't seen the same problem but haven't told me what computer, OS, C1 version, etc. that they're running the tests with. So I'm left without C1 functionality that is part of my workflow and something that was available to me when I was using an Intel machine.

    It is unfortunate that C1 support cannot provide clarification on this issue.

    0
  • Fanjan Combrink

    I'm gonna chime in here and I must say, it seems it is Ventura and C1. Not sure who's to blame but holy Pete C1 is slow on my M1 Air in the last few weeks. I haven't used it in a while but I know I have updated to Ventura in that time and it is incredibly frustrating to use C1 now. It simply wastes my time and money when other software, like LR (which I moved away from in favour of the superior C1) is a quarter of the price and seems to work waaaay faster. 

    0

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.