Skip to main content

C1 v 23 very slow on my new 24 inch imac, any solutions

Comments

11 comments

  • Bart Hovis

    Same here.  I'm using a Mac mini with 32GB and it takes about one second after moving an adjustment slider before the effect shows on the image.  I've searched for solutions to this and found none, apparently it is a problem some Mac users have and others don't.  It's so frustrating that I can't use C1, and am now using Lightroom (which performs well).

    0
  • Kassur

    Don't know if that helps, but I experienced a significant performance drop if the monitor (if you connected multiple, all of them)  doesn't run with native resolution. Scaling the resolution makes C1 awful slow. 

    Good luck,

    Kassur

    0
  • Bart Hovis

    I'm running Default resolution on Apple Studio monitor. Oddly, the performance is good except for the lagging response from adjustment sliders, but that is frustrating enough to make it unusable (to me).  BTW, same situation on my M1 MacBook. 

    0
  • Brian Jordan
    Moderator

    Check the resolution of your previews.  Settings>>Image>>Preview.  Select the size marked (Recommended).

     

    If the preview is too large or too small for your monitor, Capture One will re-render each time you open the image.

    1
  • philip sutton

    Thanks guys for chiming in and trying to help.  I've checked the resolution for previews and it is on the recommended setting (5120).  I'm at a loss - really don't know what to do.  It's basically unusable, because it takes like over a second or two for each preview to load fully.  Gear in Australia is so expensive and this new 24" iMac cost me over 2K here.  I certainly don't want to have to buy a new machine again.  We all know with weddings how many images we have to go through and with a slow machine it is a nightmare.  I'm going to a specialist Mac shop/repair place today to see if they can help.  I'll keep you posted.  

    0
  • Jerry C

    The time to view an image at maximum resolution used to be related to the window size, which implies that the preview had to be re-scaled to fit the window. This now seems to have much less of an effect than in older versions. The speed with which the image is displayed at full resolution now depends on using the  recommended resolution. The downside of setting the recommended resolution of high resolution monitors is that the preview now take up lot more storage space.

    It would be great if the speed with which the image was displayed did not depend on a preview. If the available multiple cores and threads could be optimally used, could Capture One do without previews and the issues related to them, including the space they occupy? 

    0
  • philip sutton

    Does anybody know if Lightroom is any better?  I used it years ago and it got so slow on my old 27" iMac, that I bailed and went over to C1.  I'd hate to have to swap back again, but I'd do anything to get back on the road with my editing.  Having a slow machine makes it a nightmare when you have a few thousand images to wade through.

    0
  • Bart Hovis

    Lightroom runs quite well on my Mac, but you can do a trial before committing to see how it runs on your computer.

    0
  • BeO
    Top Commenter

    I'd hate to have to swap back again, but I'd do anything to get back on the road with my editing.  Having a slow machine makes it a nightmare when you have a few thousand images to wade through.

    Then I think an option would be to install C1 version 21. I assume you can run both version 23 and version 21 on the same machine, though not recommended by C1 it was never a problem to run two versions, on Windows at least.

    0
  • FirstName LastName

    Where do you store your original image files? If you have them on an external HDD Capture One can be sluggish even on a fast computer. Even on a M1 Max MacBook Pro with 64 GB Ram. When I started storing my RAWs on a NVME drive (Crucial P5 Plus) Capture One operational speed when from barely acceptable to blazing fast. Even with an external SSD Capture One didn't perform too well.

    0
  • Leon Droby

    Try changing your Hardware Acceleration settings.  With some releases, Never works better for me than Auto.

    0

Please sign in to leave a comment.