Skip to main content

no camera support for older versions

Comments

9 comments

  • M. H. Simon

    hello, thanks for the quick reply.
    Anyway, it remains annoying.
    I can not buy a new version son c1 after each purchase of a new camera. I don't want a subscription.
    Well, it is what it is.
    Anyway, I can't use my v22 anymore and have to switch to Neo Luminar or my version of Affinity unsatisfactorily for the time being.  
    These at least work. Of course it is not a permanent solution

    0
  • M. H. Simon

    I can't make a general statement; maybe every two or three years, when a new model arouses my curiosity and is very convincing. I like Fujifilm a lot. 

     

    0
  • M. H. Simon

    I will have to think about switching to Lightroom. 
    There is a Lightroom deal again: Currently I get the annual license for Lightroom Classic incl. Photoshop, for 79,98 € and these offers are very common just before Christmas.
    A full version of v23 costs currently on offer 250€  
    I just don't feel like learning it all over again. 

    Let's see...

    0
  • M. H. Simon

    that's true, especially if I don't change my camera in the next four years.

     

    0
  • M. H. Simon

    hello, hardware limitations due to the age of the devices I understand. I also experience this with computers when the new operating system no longer supports the latest version of an application after years.
    However, I still can't understand why v22 - it's not a very old version - no longer supports my Fuji x-S20, which was launched in 23. It would not have been a problem technically.

    I rather suspect a marketing strategy, because the v23 wants to be sold.

     

    0
  • M. H. Simon

    I will work with the Adobe DNG Converter for now. So I can continue to use v22 for the next time

    1
  • Marcin Mrzygłocki
    Top Commenter

    Dear

    FirstName LastName

    FirstName LastName

    FirstName LastName

    Can you please distinguish themselves from each other?

    0
  • M. H. Simon

    Thanks for the nice answers and ideas.
    Of course I know about the possibilities to edit the RAW files of my Fuji x-s20 with other programs and I do use them.
    My point was not to find alternatives, but to express my great incomprehension about the fact that the camera I bought in June 23 is no longer compatible with the version 22 I bought 15 months ago. 

    And I stand by it: this is a big bummer and incomprehensible to me. After just one and a half years, I can no longer use my version. 
    Even with the old Affinity software, I can still edit the RAW files of my S-20 and what is possible with it should still be possible with a version from 2022. It's not Capture One's intention, the sale of new software is in the foreground and is promoted in this way.
    That is not customer-friendly. 
    And so I'm saying goodbye to Capture One for good. 
    I will not buy a new version. Neither now nor ever.

    Kind regards

    0
  • FirstName LastName

    One possible solution is to check if there's a minor update available for your software that supports the X-S20 without needing a full upgrade. Sometimes manufacturers release smaller patches to include new camera profiles.

    Another alternative could be using a free raw file converter that supports your camera model to convert your files into a compatible format for your current software version. This way, you can continue to use the tools you are familiar with without additional cost.

    Lastly, it might be helpful to express your concerns to the software company's customer service. They might have solutions or offers for loyal customers like you who are facing such issues.

    I hope one of these suggestions helps you resolve the problem!

    0

Please sign in to leave a comment.