Skip to main content

Nikon Z 9 wireless tethering with iPad doesn't connect

Comments

15 comments

  • Drazen Sokac

    Hi Juho,

    Same problem here with rhe Nikon Z8. Even tried to connect CO directly to the cams wifi, no success even the camera is listed as shoot tether over wifi. Meybe the admins of CO reads and already has a solution to this issue or even better a specific instruction for Nikon users.
    Love the fact that live view is added, now it starts to be useable as a tethering tool. Works with usb like charm

    Drazen

    0
  • Walter Rowe
    Moderator
    Top Commenter

    You may need to create a new profile on both ends (camera and capture one).

    0
  • Drazen Sokac

    Thank you Water for your quick response, already tried it with the profile on cam but how can I creat a CO profile on the ipad? Thanks in advance would be happy to try it out

    0
  • Walter Rowe
    Moderator
    Top Commenter

    On the desktop I recall needing to create a pairing for each type of connect to each camera. I assume the same is for the iPad. I would need to test it again to refresh my memory.

    0
  • Juho Vuohelainen

    Thanks Walter and Drazen for your input and confirming that there seems to be an issue here. Like Drazen pointed out, there are no separate connection profiles on iPad CO, cameras just appear on the list and you connect to them ad-hoc (at least with wireless tethering, I haven't tried wired yet). What makes me think this is an iPad CO issue is that this works on iPhone. Will try camera AP style of wireless tethering to confirm that this isn't just "infrastructure AP" issue.

    0
  • Drazen Sokac

    Hi 2 all,

    this post from Juho got me to an Idea, since it works on the iPhone. Maybe its like this: The iPhone has its connection to the internet (GSM) and "creates" a his own wifi network to enable other devices to connect through it to the net so the cam connects to this WiFi. Since the iPad has no GSM Module and connects to a WiFi it connects to the cam but CO can not communicate with the cam this way? Maybe I am completely wrong but this came to my mind and just wanted to share this and we can find a workaround together. If somebody has an iPad with GSM maybe this could be tried out.

    I think the developers should enable CO to connect directly to the Cams WiFi as it is described like enabled wireless tethering for Z8 and Z9. Another oppinions?

     

    0
  • Juho Vuohelainen

    Good news! With the latest update of CO for iPad wireless tethering seems to be working.

    I did what I did before: created a new connection profile on the camera and left it pairing while opening CO on iPad. This time selecting "Connect" on Z 9 that appeared on the list actually connected to the camera and tethering worked like a charm.

    Before I did this I tried to create a connection profile with a direct connection to iPad - unsuccessfully, because the iPad wouldn't connect to Nikon wifi. It tried a while but didn't even ask for wifi password. This seems like an issue between Apple and Nikon though, not with CO.

    0
  • Walter Rowe
    Moderator
    Top Commenter

    Each method of connecting the iPad or iPhone with the camera requires a unique profile. Wireless and Wired require separate profiles.

    0
  • Juho Vuohelainen

    Yes, this has been clear to me from the beginning. I always create a new profile on the camera for a new connection type and device. Like Drazen said, it's not possible to create connection profiles on iPad though.

    0
  • Drazen Sokac

    Yeahhhh, guys worked for me too. I even do not know if there was an update of CO but all I did now was to create a new profile on the cam and let it wait for an connection. Then i went to the ipad, found my z8 wifi in the list, connected the ipad to this wifi. Then went to COM and waited for the cam to show up in the list (took about 10sec). After this the connection works every time like charm.
    As expected this is a gently slower connection than a wired one. The live view is perfect but the transfer of my 45mbp files to the ipad takes about 11-12sec each. Wired it is in less than a sec in. So if the developers could manage to get us just an jpeg preview for transfer and save the raw files on cam, this would be the jackpot I think.
    I left COM already and went back to camranger but this is a gamechanger for me, so here I am back and very happy 😀😀

    0
  • Adriana Escalante

    I still can't connect wirelessly to my iPhone. I have a z8.  Any tips?

     

    Adriana

    0
  • Drazen Sokac

    Did you make a profile on the z8?

    0
  • Adriana Escalante

    Hi Drazen,

     

    What type of profile do I need to create?  A network profile?

    0
  • Drazen Sokac

    Hi Adriana,

    yess a network profile, when you start on the Z8/Z9 usually it calls itself WiFi1 , then follow the steps on my description above. Do NOT connect your cam through Bluetooth and then use this WiFi connection like you connect to SnapBridge, it needs a different network profile I think 

    0
  • Juho Vuohelainen

    So to connect a Nikon Z8/Z9 with CO on any device, including iPhone, "Connect to computer" option needs to be used. In that menu "Connection type" should be "Camera control" and then in "Network settings" one needs a new profile for each connection type (or maybe even device). Choose either "Search for Wifi network" to use an existing wifi network or "Direct connection to computer" to have the device connect directly to your camera using a wifi network created by the camera. I made separate profiles, one with "Direct" to use outside my home wifi and one with "Search for Wifi network" to use at home.

    "Search for Wifi", aka. "indirect", aka. "infrastructure Wifi" works for me out of the box now, but the "Direct" method required me to make the wifi connection on iPad manually by choosing "Other" on the list of wifi networks, and then entering the SSID (and password) by hand. On my first attempts without entering the SSID manually, iPad did find the camera wifi network and could attempt to join it automatically, but failed (never even asked for the password).

    Hope that helps!

    0

Please sign in to leave a comment.