Need help with older version 3.7

Comments

3 comments

  • Rob372
    Sorry wrong categories found answer. Older version not compatible with 10.5.8 osx. Ahhhhhhh

    R
    0
    Comment actions Permalink
  • Paul Steunebrink
    Download Capture One 5 (5.2.1) from the Phase One software archive. This will not only install flawlessly on 10.5.8, will give you a perfect impression of what CO 6 is capable of (and more) but will almost certain accept your CO Pro 3 license key because in general all CO Pro 3 keys include 2 logical upgrades (to 4 and 5 respectively).

    And your CO Pro 3 key is eligible for an upgrade (against a limited upgrade fee) CO Pro 6.
    0
    Comment actions Permalink
  • Drew
    And if you need any further help, create a support case and provide us your Key. We'll look up it's specifics.
    0
    Comment actions Permalink

Please sign in to leave a comment.