Skip to main content

⚠️ Please note that this topic or post has been archived. The information contained here may no longer be accurate or up-to-date. ⚠️

C1 23 Activation failed



  • Peter Todd

    I am having the same experience with activation, you're not alone :)


    Me too, same problem here on PC Dell XPS 15 Win 11 

    Once the Authentication is complete, a "An error has occurred, please try again later." message appears on the Capture One 23 splash screen. (Nov 9, 2022)

  • Peter Todd

    My problem is on Win10 64bit.
    No response from C1 team??

  • Mark V'Soske

    Same problem AND now V23 and V22 cannot open my earlier CaptureOne files.


  • Alexander Herzig

    When activate a new version C1 grep and send many data from the system to make and verify a ID. Not only the C1 executable does this. There are some windows parts that also communicate with the Capture One servers.

    It could help to do the activation with the admin profile and export the Windows Defender settings before setting the Defender to default. Afterwards the exported Defender settings can get imported to restore the old settings.

    All activations should be deactivated. And I have C1 de installed and with the new downloaded C1 23 install program new installed. Then it worked. But I also had to do this as normal user to get C1 23 working in the normal user profile.

    It always is a big trouble get a new payed version working and you have to shiver the new version is buggy. It is also difficult with the conversion of the catalog. The catalog of the old version have to converted. Afterwards it can not be opened with the older Version. Backup the catalog first and look on the date the catalog has to identify the right catalog.

    C1 has changed the resource hub. Now the edge webwiew2 is not there anymore. It is much more difficult to get the right Defender settings. But the content of the resource hub does suck anyhow. When I see the new content of the resource hub and the C1 website  I think I am wrong here. This is not for me anymore. It is not only good for nothing, it is annoying and disgusting. Time to go to Darktable.

  • Szabolcs Matefy

    I have the same issue, contacted support, tried also Trial but nothing seems to be working



Please sign in to leave a comment.